Caused: io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: /192.168.99.102:4243

DevOps

Hi Guys,

I am trying to set one Cloud Node in Jenkins. But it gives me the below error.

java.net.ConnectException: Connection refused
Caused: io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: /192.168.99.102:4243
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717)
at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:327)
at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:340)
at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:636)
at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:583)
at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:500)
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:462)
at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:897)
at io.netty.util.concurrent.FastThreadLocalRunnable.run(FastThreadLocalRunnable.java:30)
at java.lang.Thread.run(Thread.java:748)

How can I solve this error?
 


If you want to unleash your potential in this competitive field, please visit the DevOps course page for more information, where you can find the DevOps tutorials and DevOps frequently asked interview questions and answers as well.

1
Answers

Replies

The reason that you are getting this error is that you have not allowed your Jenkins node to connect with the Docker server. Open your docker configuration file with the below command.



$ vi /usr.lib.systemd/system/docker.service



Scroll down to find ExecStart parameter. Add your server IP and port address like below.



ExecStart = /usr/bin/dockerd -H tcp://<Your-IP>:<Your-port>



Save the file and close it. Now reload the daemon with the following command.



$ systemctl daemon-reload



And then restart your Docker service using the below command.



$ systemctl restart docker



You should now be able to connect your node to the Docker server.

 
 

This topic has been locked/unapproved. No replies allowed

Login to participate in this discussion.

Leave a reply

Before proceeding, please check your email for a verification link. If you did not receive the email, click here to request another.
To Top